Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Border Gateway Protocol (BGP) Parameters Last Updated 2026-09-09 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • BGP Message Types • BGP Path Attributes • BGP Error (Notification) Codes • BGP Error Subcodes • Message Header Error subcodes • OPEN Message Error subcodes • UPDATE Message Error subcodes • BGP Finite State Machine Error Subcodes • BGP Cease NOTIFICATION message subcodes • BGP ROUTE-REFRESH Message Error subcodes • BGP Outbound Route Filtering (ORF) Types • BGP OPEN Optional Parameter Types • BGP Tunnel Encapsulation Attribute Tunnel Types • BGP Tunnel Encapsulation Attribute Sub-TLVs • BGP Layer 2 Encapsulation Types • BGP Layer 2 TLV Types • BGP AIGP Attribute Types • BGP Route Refresh Subcodes • P-Multicast Service Interface Tunnel (PMSI Tunnel) Tunnel Types • P-Multicast Service Interface (PMSI) Tunnel Attribute Flags • BGP MCAST-VPN Route Types • BGP Prefix-SID TLV Types • BGP Prefix-SID Label-Index TLV Flags • BGP Prefix-SID Originator SRGB TLV Flags • BGP Graceful Restart Flags • BGP Graceful Restart Flags for Address Family • SFP Attribute TLVs • SFP Association Type • SFC SPI/SI Representation Flags • BFD Mode • BFD Discriminator Optional TLV Type • SRv6 Service Sub-TLV Types • SRv6 Service Data Sub-Sub-TLV Types • BGP SRv6 Service SID Flags • Long-Lived Graceful Restart Flags for Address Family • BGP BIER TLV and Sub-TLV Types • BGP CAR NLRI Types • BGP CAR NLRI TLV Types • Next Hop Dependent Characteristic Codes • VPN Prefix ORF TLV Type • ORF Entry Bits BGP Message Types Registration Procedure(s) Standards Action Reference [RFC 4271] Available Formats [IMG] CSV Value Name Reference 0 Reserved 1 OPEN [RFC 4271] 2 UPDATE [RFC 4271] 3 NOTIFICATION [RFC 4271] 4 KEEPALIVE [RFC 4271] 5 ROUTE-REFRESH [RFC 2918] 6-255 Unassigned BGP Path Attributes Registration Procedure(s) Standards Action Reference [RFC 4271] Available Formats [IMG] CSV Value Code Reference 0 Reserved 1 ORIGIN [RFC 4271] 2 AS_PATH [RFC 4271] 3 NEXT_HOP [RFC 4271] 4 MULTI_EXIT_DISC [RFC 4271] 5 LOCAL_PREF [RFC 4271] 6 ATOMIC_AGGREGATE [RFC 4271] 7 AGGREGATOR [RFC 4271] 8 COMMUNITIES [RFC 1997] 9 ORIGINATOR_ID [RFC 4456] 10 CLUSTER_LIST [RFC 4456] 11 DPA (deprecated) [Chen, E., Bates, T., "Destination Preference Attribute for BGP", Work in progress, March 1996.]; [RFC 6938] 12 ADVERTISER (historic) (deprecated) [RFC 1863]; [RFC 4223]; [RFC 6938] 13 RCID_PATH / CLUSTER_ID (Historic) (deprecated) [RFC 1863]; [RFC 4223]; [RFC 6938] 14 MP_REACH_NLRI [RFC 4760] 15 MP_UNREACH_NLRI [RFC 4760] 16 EXTENDED COMMUNITIES [Eric_Rosen]; [draft-ramachandra-bgp-ext-communities-00]; [RFC-ietf-idr-rfc4360-bis-09] 17 AS4_PATH [RFC 6793] 18 AS4_AGGREGATOR [RFC 6793] 19 SAFI Specific Attribute (SSA) (deprecated) [Gargi_Nalawade]; [draft-kapoor-nalawade-idr-bgp-ssa-00]; [draft-nalawade-idr-mdt-safi-00]; [draft-wijnands-mt-discovery-00] 20 Connector Attribute (deprecated) [RFC 6037] 21 AS_PATHLIMIT (deprecated) [draft-ietf-idr-as-pathlimit-02] 22 PMSI_TUNNEL [RFC 6514] 23 Tunnel Encapsulation [RFC 9012] 24 Traffic Engineering [RFC 5543] 25 IPv6 Address Specific Extended Community [RFC 5701] 26 AIGP [RFC 7311] 27 PE Distinguisher Labels [RFC 6514] 28 BGP Entropy Label Capability Attribute (deprecated) [RFC 6790]; [RFC 7447] 29 BGP-LS Attribute [RFC 9552] 30 Deprecated [RFC 8093] 31 Deprecated [RFC 8093] 32 LARGE_COMMUNITY [RFC 8092] 33 BGPsec_Path [RFC 8205] BGP Community Container Attribute (TEMPORARY - 34 registered 2017-07-28, extension registered 2024-08-22, [draft-ietf-idr-wide-bgp-communities-11] expires 2025-07-28) 35 Only to Customer (OTC) [RFC 9234] 36 BGP Domain Path (D-PATH) [RFC 10039] 37 SFP attribute [RFC 9015] 38 BFD Discriminator [RFC 9026] 39 Next Hop Dependent Characteristic (NHC) [RFC-ietf-idr-nhc-07] 40 BGP Prefix-SID [RFC 8669] 41 BIER [RFC 9793] Edge Metadata Path Attribute (TEMPORARY - registered 42 2025-04-23, extension registered 2026-04-03, expires [draft-ietf-idr-5g-edge-service-metadata-27] 2027-04-23) 43-127 Unassigned 128 ATTR_SET [RFC 6368] 129 Deprecated [RFC 8093] 130-240 Unassigned 241 Deprecated [RFC 8093] 242 Deprecated [RFC 8093] 243 Deprecated [RFC 8093] 244-254 Unassigned 255 Reserved for development [RFC 2042] BGP Error (Notification) Codes Registration Procedure(s) Standards Action Reference [RFC 4271][RFC 7313] Available Formats [IMG] CSV Value Name Reference 0 Reserved 1 Message Header Error [RFC 4271] 2 OPEN Message Error [RFC 4271] 3 UPDATE Message Error [RFC 4271] 4 Hold Timer Expired [RFC 4271] 5 Finite State Machine Error [RFC 4271] 6 Cease [RFC 4271] 7 ROUTE-REFRESH Message Error [RFC 7313] 8 Send Hold Timer Expired [RFC 9687] 9 Loss of LSDB Synchronization [RFC 9815] 10-255 Unassigned BGP Error Subcodes Registration Procedure(s) Standards Action Reference [RFC 4271] Message Header Error subcodes Registration Procedure(s) Standards Action Reference [RFC 4271] Available Formats [IMG] CSV Value Name Reference 0 Unspecific [RFC Errata 4493] 1 Connection Not Synchronized [RFC 4271] 2 Bad Message Length [RFC 4271] 3 Bad Message Type [RFC 4271] 4-255 Unassigned OPEN Message Error subcodes Registration Procedure(s) Standards Action Reference [RFC 4271] Available Formats [IMG] CSV Value Name Reference 0 Unspecific [RFC Errata 4493] 1 Unsupported Version Number [RFC 4271] 2 Bad Peer AS [RFC 4271] 3 Bad BGP Identifier [RFC 4271] 4 Unsupported Optional Parameter [RFC 4271] 5 [Deprecated] [RFC 4271] 6 Unacceptable Hold Time [RFC 4271] 7 Unsupported Capability [RFC 5492] 8 Deprecated [RFC 9234] 9 Deprecated [RFC 9234] 10 Deprecated [RFC 9234] 11 Role Mismatch [RFC 9234] 12-255 Unassigned UPDATE Message Error subcodes Registration Procedure(s) Standards Action Reference [RFC 4271] Available Formats [IMG] CSV Value Name Reference 0 Unspecific [RFC Errata 4493] 1 Malformed Attribute List [RFC 4271] 2 Unrecognized Well-known Attribute [RFC 4271] 3 Missing Well-known Attribute [RFC 4271] 4 Attribute Flags Error [RFC 4271] 5 Attribute Length Error [RFC 4271] 6 Invalid ORIGIN Attribute [RFC 4271] 7 [Deprecated] [RFC 4271] 8 Invalid NEXT_HOP Attribute [RFC 4271] 9 Optional Attribute Error [RFC 4271] 10 Invalid Network Field [RFC 4271] 11 Malformed AS_PATH [RFC 4271] 12-255 Unassigned BGP Finite State Machine Error Subcodes Registration Procedure(s) Standards Action Reference [RFC 6608] Available Formats [IMG] CSV Value Name Reference 0 Unspecified Error [RFC 6608] 1 Receive Unexpected Message in OpenSent State [RFC 6608] 2 Receive Unexpected Message in OpenConfirm State [RFC 6608] 3 Receive Unexpected Message in Established State [RFC 6608] 4-255 Unassigned BGP Cease NOTIFICATION message subcodes Registration Procedure(s) Standards Action or Early IANA Allocation process Reference [RFC 4486] Available Formats [IMG] CSV Value Name Reference 0 Reserved 1 Maximum Number of Prefixes Reached [RFC 4486] 2 Administrative Shutdown [RFC 4486]; [RFC 9003] 3 Peer De-configured [RFC 4486] 4 Administrative Reset [RFC 4486]; [RFC 9003] 5 Connection Rejected [RFC 4486] 6 Other Configuration Change [RFC 4486] 7 Connection Collision Resolution [RFC 4486] 8 Out of Resources [RFC 4486] 9 Hard Reset [RFC 8538] 10 BFD Down [RFC 9384] 11-255 Unassigned BGP ROUTE-REFRESH Message Error subcodes Reference [RFC 7313] Available Formats [IMG] CSV Range Registration Procedures 0-127 Standards Action 128-255 First Come First Served Value Name Reference 0 Reserved [RFC 7313] 1 Invalid Message Length [RFC 7313] 2-255 Unassigned BGP Outbound Route Filtering (ORF) Types Reference [RFC 5291] Available Formats [IMG] CSV Range Registration Procedures Note 0-63 Standards Action 64-127 First Come First Served 128-255 Vendor-Specific IANA does not assign Value Description Reference 0 Reserved [RFC 5291] 1-63 Unassigned 64 Address Prefix ORF [RFC 5292] 65 CP-ORF [RFC 7543] 66 VPN Prefix ORF [RFC-ietf-idr-vpn-prefix-orf-45] 67-127 Unassigned 128-255 Reserved for Vendor-Specific [RFC 5291] BGP OPEN Optional Parameter Types Registration Procedure(s) IETF Review Reference [RFC 5492] Available Formats [IMG] CSV Value Name Reference 0 Reserved [RFC 5492] 1 Authentication (deprecated) [RFC 4271]; [RFC 5492] 2 Capabilities [RFC 5492] 3-254 Unassigned 255 Extended Length [RFC 9072] BGP Tunnel Encapsulation Attribute Tunnel Types Reference [RFC 9012] Note Moved to [Border Gateway Protocol (BGP) Tunnel Encapsulation] per [RFC 9012]. BGP Tunnel Encapsulation Attribute Sub-TLVs Reference [RFC 9012] Note Moved to [Border Gateway Protocol (BGP) Tunnel Encapsulation] per [RFC 9012]. BGP Layer 2 Encapsulation Types Reference [RFC 6624] Note When this registry is modified, the YANG module [iana-bgp-l2-encaps] must be updated as defined in [RFC 9291]. Available Formats [IMG] CSV Range Registration Procedures 0-127 Expert Review 128-251 First Come First Served 252-255 Experimental Use Value Description Reference 0 Reserved [RFC 6624] 1 Frame Relay [RFC 4446] 2 ATM AAL5 SDU VCC transport [RFC 4446] 3 ATM transparent cell transport [RFC 4816] 4 Ethernet (VLAN) Tagged Mode [RFC 4448] 5 Ethernet Raw Mode [RFC 4448] 6 Cisco HDLC [RFC 4618] 7 PPP [RFC 4618] 8 SONET/SDH Circuit Emulation Service [RFC 4842] 9 ATM n-to-one VCC cell transport [RFC 4717] 10 ATM n-to-one VPC cell transport [RFC 4717] 11 IP Layer 2 Transport [RFC 3032] 12-14 Unassigned 15 Frame Relay Port mode [RFC 4619] 16 Unassigned 17 Structure-agnostic E1 over packet [RFC 4553] 18 Structure-agnostic T1 (DS1) over packet [RFC 4553] 19 VPLS [RFC 4761] 20 Structure-agnostic T3 (DS3) over packet [RFC 4553] 21 Nx64kbit/s Basic Service using Structure-aware [RFC 5086] 22-24 Unassigned 25 Frame Relay DLCI [RFC 4619] 25-39 Unassigned 40 Structure-agnostic E3 over packet [RFC 4553] 41 Octet-aligned payload for Structure-agnostic DS1 circuits [RFC 4553] 42 E1 Nx64kbit/s with CAS using Structure-aware [RFC 5086] 43 DS1 (ESF) Nx64kbit/s with CAS using Structure-aware [RFC 5086] 44 DS1 (SF) Nx64kbit/s with CAS using Structure-aware [RFC 5086] 45-251 Unassigned 252-255 Experimental Use [RFC 6624] BGP Layer 2 TLV Types Reference [RFC 6624] Available Formats [IMG] CSV Range Registration Procedures 0-127 Expert Review 128-251 First Come First Served 252-255 Experimental Use Value Description Reference 0 Reserved [RFC 6624] 1 Circuit Status Vector [RFC 6624] 2-127 Unassigned 128-251 Unassigned 252-255 Experimental Use [RFC 6624] BGP AIGP Attribute Types Registration Procedure(s) Standards Action Reference [RFC 7311] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7311] 1 AIGP [RFC 7311] 2-255 Unassigned BGP Route Refresh Subcodes Reference [RFC 7313] Available Formats [IMG] CSV Range Registration Procedures 0-127 Standards Action 128-254 First Come First Served Value Code Reference 0 Route-Refresh [RFC 2918]; [RFC 5291] 1 BoRR [RFC 7313] 2 EoRR [RFC 7313] 3-254 Unassigned 255 Reserved [RFC 7313] P-Multicast Service Interface Tunnel (PMSI Tunnel) Tunnel Types Reference [RFC 7385][RFC 8317] Note The status of value 0xFF may only be changed through Standards Action [RFC 8126]. Available Formats [IMG] CSV Range Registration Procedures 0x00-0x7A IETF Review 0x7B-0x7E Experimental Use 0x80-0xFA Composite Tunnel 0xFB-0xFE Experimental Use 0xFF Standards Action Value Meaning Reference 0x00 no tunnel information present [RFC 6514] 0x01 RSVP-TE P2MP LSP [RFC 6514] 0x02 mLDP P2MP LSP [RFC 6514] 0x03 PIM-SSM Tree [RFC 6514] 0x04 PIM-SM Tree [RFC 6514] 0x05 BIDIR-PIM Tree [RFC 6514] 0x06 Ingress Replication [RFC 6514] 0x07 mLDP MP2MP LSP [RFC 6514] 0x08 Transport Tunnel [RFC 7524] 0x09 Unassigned 0x0A Assisted Replication Tunnel [RFC 9574] 0x0B BIER [RFC 8556] 0x0C SR-MPLS P2MP Tree [RFC 10018] 0x0D SRv6 P2MP Tree [RFC 10018] 0x0E-0x7A Unassigned 0x7B-0x7E Reserved for Experimental Use [RFC 8317] 0x7F Reserved [RFC 8317] 0x80-0xFA Reserved for Composite Tunnel [RFC 8317] 0xFB-0xFE Reserved for Experimental Use [RFC 7385] 0xFF wildcard transport tunnel type [RFC 8338] P-Multicast Service Interface (PMSI) Tunnel Attribute Flags Registration Procedure(s) Standards Action Reference [RFC 7902] Available Formats [IMG] CSV Value Name Reference 0 Unassigned 1 Extension [RFC 7902] 2 Leaf Information Required per-Flow (LIR-pF) [RFC 8534] 3-4 Assisted Replication Type (T) [RFC 9574] 5 Broadcast and Multicast (BM) [RFC 9574] 6 Unknown (U) [RFC 9574] 7 Leaf Information Required (L) [RFC 6514] BGP MCAST-VPN Route Types Registration Procedure(s) Standards Action Reference [RFC 7441][RFC 6514] Note Values may be assigned from one of several ranges: - Range 0x01-0x3f: Generic/PIM Range. Values are assigned from this range when the NLRI format associated with the route type presupposes that PIM or IGMP is the C-multicast control protocol, or when the NLRI format associated with the route type is independent of the C-multicast control protocol. - Range 0x43-0x7f: mLDP Range. Values are assigned from this range when the NLRI format associated with the route type presupposes that mLDP is the C-multicast control protocol. - Range 0x80-0xff: This range is reserved; values should not be assigned from this range. In general, whenever an assignment is requested from this registry, two codepoints should be requested at the same time: one from the Generic/PIM range (0x01-0x3f) and one from the mLDP range (0x43-0x7f). The two codepoints should have the same low-order 6 bits. If one of the two codepoints is not actually needed, it should be registered anyway, and marked as "Reserved." Available Formats [IMG] CSV Value Meaning Reference 0x00 Reserved [RFC 7441]; [RFC 6514] 0x01 Intra-AS I-PMSI A-D route [RFC 7441]; [RFC 6514] 0x02 Inter-AS I-PMSI A-D route [RFC 7441]; [RFC 6514] 0x03 S-PMSI A-D route [RFC 7441]; [RFC 6514] 0x04 Leaf A-D route [RFC 7441]; [RFC 6514] 0x05 Source Active A-D route [RFC 7441]; [RFC 6514] 0x06 Shared Tree Join route [RFC 7441]; [RFC 6514] 0x07 Source Tree Join route [RFC 7441]; [RFC 6514] 0x08-0x3f Unassigned (Generic/PIM range) 0x40-0x42 Reserved [RFC 7441] 0x43 S-PMSI A-D route for C-multicast mLDP [RFC 7441] 0x44 Leaf A-D route for C-multicast mLDP [RFC 7441] 0x45-0x46 Reserved [RFC 7441] 0x47 Source Tree Join route for C-multicast mLDP [RFC 7441] 0x48-0x7f Unassigned (mLDP range) 0x80-0xff Reserved [RFC 7441] BGP Prefix-SID TLV Types Registration Procedure(s) Expert Review Expert(s) Acee Lindem, Hannes Gredler Reference [RFC 8669] Available Formats [IMG] CSV Value Type Reference 0 Reserved [RFC 8669] 1 Label-Index [RFC 8669] 2 Deprecated [RFC 8669] 3 Originator SRGB [RFC 8669] 4 Deprecated [RFC 9252] 5 SRv6 L3 Service TLV [RFC 9252] 6 SRv6 L2 Service TLV [RFC 9252] 7 SRv6 Transport TLV [draft-sa-idr-bgp-srv6-mpls-transport-iw-02] 8-254 Unassigned 255 Reserved [RFC 8669] BGP Prefix-SID Label-Index TLV Flags Registration Procedure(s) Expert Review Expert(s) Acee Lindem, Hannes Gredler Reference [RFC 8669] Available Formats [IMG] CSV Value Name Reference 0x0001-0x8000 Unassigned BGP Prefix-SID Originator SRGB TLV Flags Registration Procedure(s) Expert Review Expert(s) Acee Lindem, Hannes Gredler Reference [RFC 8669] Available Formats [IMG] CSV Value Name Reference 0x0001-0x8000 Unassigned BGP Graceful Restart Flags Registration Procedure(s) Standards Action Reference [RFC 4724][RFC 8538] Available Formats [IMG] CSV Bit Position Name Short Name Reference 0 Restart State R [RFC 4724] 1 Notification N [RFC 8538] 2-3 Unassigned BGP Graceful Restart Flags for Address Family Registration Procedure(s) Standards Action Reference [RFC 4724][RFC 8538] Available Formats [IMG] CSV Bit Position Name Short Name Reference 0 Forwarding State F [RFC 4724] 1-7 Unassigned SFP Attribute TLVs Registration Procedure(s) First Come First Served Reference [RFC 9015] Available Formats [IMG] CSV Type Name Reference Registration Date 0 Reserved [RFC 9015] 1 Association TLV [RFC 9015] 2020-09-02 2 Hop TLV [RFC 9015] 2020-09-02 3 SFT TLV [RFC 9015] 2020-09-02 4 MPLS Swapping/Stacking [RFC 9015] 2020-09-02 5 SFP Traversal With MPLS [RFC 9015] 2020-09-02 6-65534 Unassigned 65535 Reserved [RFC 9015] SFP Association Type Registration Procedure(s) First Come First Served Reference [RFC 9015] Available Formats [IMG] CSV Association Type Name Reference Registration Date 0 Reserved [RFC 9015] 1 Bidirectional SFP [RFC 9015] 2020-09-02 2-65534 Unassigned 65535 Reserved [RFC 9015] SFC SPI/SI Representation Flags Registration Procedure(s) Standards Action Reference [RFC 9015] Available Formats [IMG] CSV Value Name Reference 0 NSH data plane [RFC 9015] 1 MPLS data plane [RFC 9015] 2-15 Unassigned BFD Mode Reference [RFC 9026] Available Formats [IMG] CSV Range Registration Procedures 0-175 IETF Review 176-249 First Come First Served 250-254 Experimental Use 255 IETF Review Value Description Reference 0 Reserved [RFC 9026] 1 P2MP BFD Session [RFC 9026] 2-175 Unassigned 176 S-BFD for SRv6 Locator Session [draft-wang-bess-sbfd-discriminator-04] 177 S-BFD for Common Session [draft-wang-bess-sbfd-discriminator-04] 178-249 Unassigned 250-254 Experimental Use [RFC 9026] 255 Reserved [RFC 9026] BFD Discriminator Optional TLV Type Reference [RFC 9026] Available Formats [IMG] CSV Range Registration Procedures 0-175 IETF Review 176-249 First Come First Served 250-254 Experimental Use 255 IETF Review Value Description Reference 0 Reserved [RFC 9026] 1 Source IP Address [RFC 9026] 2-175 Unassigned 176-249 Unassigned 250-254 Experimental Use [RFC 9026] 255 Reserved [RFC 9026] SRv6 Service Sub-TLV Types Reference [RFC 9252] Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review 128-254 First Come First Served 255 IETF Review Value Type Reference 0 Reserved [RFC 9252] 1 SRv6 SID Information Sub-TLV [RFC 9252] 2-254 Unassigned 255 Reserved [RFC 9252] SRv6 Service Data Sub-Sub-TLV Types Reference [RFC 9252] Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review 128-254 First Come First Served 255 IETF Review Value Type Reference 0 Reserved [RFC 9252] 1 SRv6 SID Structure Sub-Sub-TLV [RFC 9252] 2-254 Unassigned 255 Reserved [RFC 9252] BGP SRv6 Service SID Flags Registration Procedure(s) IETF Review Reference [RFC 9252] Available Formats [IMG] CSV Bit Position Name Reference 0-7 Unassigned Long-Lived Graceful Restart Flags for Address Family Registration Procedure(s) Standards Action Reference [RFC 9494] Available Formats [IMG] CSV Bit Position Name Short Name Reference 0 Preservation of state F [RFC 9494] 1-7 Unassigned BGP BIER TLV and Sub-TLV Types Registration Procedure(s) First Come First Served Reference [RFC 9793] Available Formats [IMG] CSV Value Name Reference 0 Reserved [RFC 9793] 1 BIER TLV [RFC 9793] 2 MPLS Encapsulation sub-TLV [RFC 9793] 3 non-MPLS Encapsulation sub-TLV [RFC 9793] 4 BIER Nexthop sub-TLV [RFC 9793] 5 BIER PHP Request [RFC-ietf-bier-php-16] 6-65535 Unassigned BGP CAR NLRI Types Registration Procedure(s) Specification Required Expert(s) Bruno Decraene, Swadesh Agrawal Reference [RFC 9871] Available Formats [IMG] CSV Type NLRI Type Reference 0 Reserved [RFC 9871] 1 Color-Aware Route [RFC 9871] 2 IP Prefix [RFC 9871] 3-255 Unassigned BGP CAR NLRI TLV Types Registration Procedure(s) Specification Required Expert(s) Bruno Decraene, Swadesh Agrawal Reference [RFC 9871] Available Formats [IMG] CSV Type NLRI TLV Type Reference 0 Reserved [RFC 9871] 1 Label [RFC 9871] 2 Label-Index [RFC 9871] 3 SRv6 SID [RFC 9871] 4-64 Unassigned Next Hop Dependent Characteristic Codes Registration Procedure(s) First Come First Served Reference [RFC-ietf-idr-nhc-07] Available Formats [IMG] CSV Range Registration Procedures 0 Reserved 1-65399 First Come First Served 65400-65499 Private Use 65500-65534 Experimental Use 65535 Reserved Value Description Reference Change Controller 0 Reserved [RFC-ietf-idr-nhc-07] IETF 1 ELCv3 [draft-ietf-idr-elc-00] IETF 2 NNHN [draft-ietf-idr-next-next-hop-nodes-00] IETF 3 BGPID [RFC-ietf-idr-nhc-07] IETF 4 IFIT [draft-ietf-idr-bgp-ifit-capabilities-05] IETF 5 AMetric [draft-ietf-idr-bgp-generic-metric-01] IETF 6-65399 Unassigned 65400-65499 Reserved for Private Use [RFC-ietf-idr-nhc-07] IETF 65500-65534 Reserved for Experimental Use [RFC-ietf-idr-nhc-07] IETF 65535 Reserved [RFC-ietf-idr-nhc-07] IETF VPN Prefix ORF TLV Type Reference [RFC-ietf-idr-vpn-prefix-orf-45] Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review 128-255 First Come First Served Value Description Reference 0 Reserved [RFC-ietf-idr-vpn-prefix-orf-45] 1 IPv4 Source PE TLV [RFC-ietf-idr-vpn-prefix-orf-45] 2 IPv6 Source PE TLV [RFC-ietf-idr-vpn-prefix-orf-45] 3 Source PE Identifier TLV [RFC-ietf-idr-vpn-prefix-orf-45] 4 Route Target TLV [RFC-ietf-idr-vpn-prefix-orf-45] 5 Route Type TLV [RFC-ietf-idr-vpn-prefix-orf-45] 6-255 Unassigned ORF Entry Bits Registration Procedure(s) IETF Review Reference [RFC-ietf-idr-vpn-prefix-orf-45] Available Formats [IMG] CSV Bit Position Name Description Reference 0-1 Action The value of this field is 0 for ADD, 1 for REMOVE, and 2 for [RFC 5291] REMOVE-ALL. 2 Match The value of this field is 0 for PERMIT and 1 for DENY. [RFC 5291] The value of this field is 0 for withdrawn all overload VPN routes, 3 Overload VPN routes process method and 1 for refusing to receive VPN routes matching the overload [RFC-ietf-idr-vpn-prefix-orf-45] criteria. 4-7 Unassigned Contact Information ID Name Contact URI Last Updated [Eric_Rosen] Eric Rosen mailto:erosen&cisco.com 2010-02-23 [Gargi_Nalawade] Gargi Nalawade mailto:gargi&cisco.com 2004-02 Licensing Terms