Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Bidirectional Forwarding Detection (BFD) Parameters Created 2010-03-29 Last Updated 2026-07-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • BFD Diagnostic Codes • BFD Authentication Types BFD Diagnostic Codes Registration Procedure(s) Expert Review Expert(s) Jeff Haas, Les Ginsberg Reference [RFC 5880] Note Updates to this registry must be mirrored in MIB module [IANA-BFD-TC-STD-MIB] and YANG module [iana-bfd-types]. See [RFC 7730] and [RFC 9127]. Available Formats [IMG] CSV Value BFD Diagnostic Code Name Reference 0 No Diagnostic [RFC 5880] 1 Control Detection Time Expired [RFC 5880] 2 Echo Function Failed [RFC 5880] 3 Neighbor Signaled Session Down [RFC 5880] 4 Forwarding Plane Reset [RFC 5880] 5 Path Down [RFC 5880] 6 Concatenated Path Down [RFC 5880] 7 Administratively Down [RFC 5880] 8 Reverse Concatenated Path Down [RFC 5880] 9 mis-connectivity defect [RFC 6428] 10-31 Unassigned BFD Authentication Types Registration Procedure(s) Expert Review Expert(s) Jeff Haas, Les Ginsberg Reference [RFC 5880] Note Updates to this registry must be mirrored in MIB module [IANA-BFD-TC-STD-MIB] and YANG module [iana-bfd-types]. See [RFC 7730] and [RFC 9127]. Available Formats [IMG] CSV Address BFD Authentication Type Name Reference 0 Reserved [RFC 5880] 1 Simple Password [RFC 5880] 2 Keyed MD5 [RFC 5880] 3 Meticulous Keyed MD5 [RFC 5880] 4 Keyed SHA1 [RFC 5880] 5 Meticulous Keyed SHA1 [RFC 5880] 6 NULL [RFC 9978] 7 Optimized MD5 Meticulous Keyed ISAAC Authentication [RFC 9986] 8 Optimized SHA-1 Meticulous Keyed ISAAC Authentication [RFC 9986] 9-255 Unassigned Licensing Terms