Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Address Resolution Protocol (ARP) Parameters Last Updated 2023-05-19 Note Reverse Address Resolution Protocol Operation Codes The Reverse Address Resolution Protocol (RARP) specified in [RFC 903] uses the "Reverse" codes below. DYNAMIC REVERSE ARP The Dynamic Reverse Address Resolution Protocol (DRARP) uses the "DRARP" codes below. For further information, see [RFC 1931]. INVERSE ADDRESS RESOLUTION PROTOCOL The Inverse Address Resolution Protocol (IARP) specified in [RFC 2390] uses the "InARP" codes below. Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Operation Codes • Hardware Types • Protocol Type Operation Codes Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 826][RFC 5494] Available Formats [IMG] CSV Number Operation Code (op) References 0 Reserved [RFC 5494] 1 REQUEST [RFC 826]; [RFC 5227] 2 REPLY [RFC 826]; [RFC 5227] 3 request Reverse [RFC 903] 4 reply Reverse [RFC 903] 5 DRARP-Request [RFC 1931] 6 DRARP-Reply [RFC 1931] 7 DRARP-Error [RFC 1931] 8 InARP-Request [RFC 2390] 9 InARP-Reply [RFC 2390] 10 ARP-NAK [RFC 1577] 11 MARS-Request [Grenville_Armitage] 12 MARS-Multi [Grenville_Armitage] 13 MARS-MServ [Grenville_Armitage] 14 MARS-Join [Grenville_Armitage] 15 MARS-Leave [Grenville_Armitage] 16 MARS-NAK [Grenville_Armitage] 17 MARS-Unserv [Grenville_Armitage] 18 MARS-SJoin [Grenville_Armitage] 19 MARS-SLeave [Grenville_Armitage] 20 MARS-Grouplist-Request [Grenville_Armitage] 21 MARS-Grouplist-Reply [Grenville_Armitage] 22 MARS-Redirect-Map [Grenville_Armitage] 23 MAPOS-UNARP [Mitsuru_Maruyama]; [RFC 2176] 24 OP_EXP1 [RFC 5494] 25 OP_EXP2 [RFC 5494] 26-65534 Unassigned 65535 Reserved [RFC 5494] Hardware Types Expert(s) Carlos Pignataro Reference [RFC 826][RFC 5494] Available Formats [IMG] CSV Range Registration Procedures Note requests for values below 256 Expert Review requests for more than one value Expert Review requests for one value greater than 255 First Come First Served requests for one value, no value specified First Come First Served can only be assigned a two-octet value (i.e., a value greater than 255) Number Hardware Type (hrd) Reference 0 Reserved [RFC 5494] 1 Ethernet (10Mb) [Jon_Postel] 2 Experimental Ethernet (3Mb) [Jon_Postel] 3 Amateur Radio AX.25 [Philip_Koch] 4 Proteon ProNET Token Ring [Avri_Doria] 5 Chaos [Gill_Pratt] 6 IEEE 802 Networks [Jon_Postel] 7 ARCNET [RFC 1201] 8 Hyperchannel [Jon_Postel] 9 Lanstar [Tom_Unger] 10 Autonet Short Address [Mike_Burrows] 11 LocalTalk [Joyce_K_Reynolds] 12 LocalNet (IBM PCNet or SYTEK LocalNET) [Joseph Murdock] 13 Ultra link [Rajiv_Dhingra] 14 SMDS [George_Clapp] 15 Frame Relay [Andy_Malis] 16 Asynchronous Transmission Mode (ATM) [[JXB2]] 17 HDLC [Jon_Postel] 18 Fibre Channel [RFC 4338] 19 Asynchronous Transmission Mode (ATM) [RFC 2225] 20 Serial Line [Jon_Postel] 21 Asynchronous Transmission Mode (ATM) [Mike_Burrows] 22 MIL-STD-188-220 [Herb_Jensen] 23 Metricom [Jonathan_Stone] 24 IEEE 1394.1995 [Myron_Hattig] 25 MAPOS [Mitsuru_Maruyama]; [RFC 2176] 26 Twinaxial [Marion_Pitts] 27 EUI-64 [Kenji_Fujisawa] 28 HIPARP [Jean_Michel_Pittet] 29 IP and ARP over ISO 7816-3 [Scott_Guthery] 30 ARPSec [Jerome_Etienne] 31 IPsec tunnel [RFC 3456] 32 InfiniBand (TM) [RFC 4391] 33 TIA-102 Project 25 Common Air Interface (CAI) [Jeff Anderson, Telecommunications Industry of America (TIA) TR-8.5 Formulating Group, , June 2004] 34 Wiegand Interface [Scott_Guthery_2] 35 Pure IP [Inaky_Perez-Gonzalez] 36 HW_EXP1 [RFC 5494] 37 HFI [Tseng-Hui_Lin] 38 Unified Bus (UB) [Wei_Pan] 39-255 Unassigned 256 HW_EXP2 [RFC 5494] 257 AEthernet [Geoffroy_Gramaize] 258-65534 Unassigned 65535 Reserved [RFC 5494] Protocol Type Registration Procedure(s) The Ethertype space is administered as described in [RFC 5342]. Reference [RFC 826][RFC 5494][RFC 5342] Note These numbers share the Ethertype space. See [IANA OUI Ethernet Numbers]. No registrations at this time. Contact Information ID Name Contact URI Last Updated [Andy_Malis] Andy Malis mailto:agmalis&gmail.com 2013-05-28 [Avri_Doria] Avri Doria mailto:avri&peoteon.com 1994-12 [Geoffroy_Gramaize] Geoffroy Gramaize mailto:geoffroy.iana&gramaize.eu 2016-07-20 [George_Clapp] George Clapp mailto:meritec!clapp&bellcore.bellcore.com [Gill_Pratt] Gill Pratt mailto:gill%25mit-ccc@mc.lcs.mit.edu [Grenville_Armitage] Grenville Armitage mailto:gja&thumper.belcore.com 1995-04 [Herb_Jensen] Herb Jensen mailto:hwjensen&itt.com 1995-02 [Inaky_Perez-Gonzalez] Inaky Perez-Gonzalez mailto:inaky.perez-gonzalez&intel.com 2008-10-01 [Jean_Michel_Pittet] Jean-Michel Pittet mailto:jmp&gandalf.engr.sgi.com 1998-11 [Jerome_Etienne] Jerome Etienne mailto:jetienne&arobas.net 2000-06 [Jon_Postel] Jon Postel mailto:postel&isi.edu [Jonathan_Stone] Jonathan Stone mailto:jonathan&dsg.stanford.edu 1996-05 [Joyce_K_Reynolds] Joyce K. Reynolds mailto:jkrey&isi.edu [Kenji_Fujisawa] Kenji Fujisawa mailto:fujisawa&sm.sony.co.jp 1998-10 [Marion_Pitts] Marion Pitts mailto:marionp&vnet.ibm.com 1997-05 [Mike_Burrows] Mike Burrows mailto:burrows&src.dec.com [Mitsuru_Maruyama] Mitsuru Maruyama mailto:mitsuru&ntt-20.ecl.net 1997-03 [Myron_Hattig] Myron Hattig mailto:Myron_Hattig&ccm.jf.intel.com 1997-02 [Philip_Koch] Philip Koch mailto:Philip.Koch&dartmouth.edu [Rajiv_Dhingra] Rajiv Dhingra mailto:rajiv&ultra.com [Scott_Guthery] Scott Guthery mailto:sguthery&mobile-mind.com 2000-03 [Scott_Guthery_2] Scott Guthery mailto:sguthery&hidcorp.com 2008-09-25 [Tom_Unger] Tom Unger mailto:tom&citi.umich [Tseng-Hui_Lin] Tseng-Hui Lin mailto:tsenglin&us.ibm.com [Wei_Pan] Wei Pan mailto:tarzan.pan&huawei.com 2023-05-19 Licensing Terms