Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Application-Layer Traffic Optimization (ALTO) Protocol Created 2014-03-18 Last Updated 2023-08-14 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • ALTO Cost Modes • ALTO Cost Metrics • ALTO Cost Source Types • ALTO Endpoint Property Types • ALTO Address Types • ALTO Error Codes • ALTO Entity Domain Types • ALTO Entity Property Types ALTO Cost Modes Registration Procedure(s) IETF Review Reference [RFC 9274] Note Identifiers prefixed with "priv:" are reserved for Private Use (see [RFC 9274, Section 5]). Available Formats [IMG] CSV Identifier Description Intended Semantics Reference numerical Indicates that numerical operations can be performed on the returned costs [Section 6.1.2.1 of RFC 7285] [RFC 9274] ordinal Indicates that the cost values in a cost map represent ranking [Section 6.1.2.2 of RFC 7285] [RFC 9274] array Indicates that the cost value is a JSON array [Section 6.5.2 of RFC 9275] [RFC 9275] ALTO Cost Metrics Registration Procedure(s) IETF Review Reference [RFC 7285][RFC Errata 6874] Note Identifiers prefixed with "priv:" are reserved for Private Use (see [RFC 7285, Section 10.6]). Available Formats [IMG] CSV Identifier Intended Semantics Reference routingcost See [Section 6.1.1.1 of RFC 7285] [RFC 7285] delay-ow See [Section 4.1 of RFC 9439] [RFC 9439] delay-rt See [Section 4.2 of RFC 9439] [RFC 9439] delay-variation See [Section 4.3 of RFC 9439] [RFC 9439] lossrate See [Section 4.4 of RFC 9439] [RFC 9439] hopcount See [Section 4.5 of RFC 9439] [RFC 9439] tput See [Section 5.1 of RFC 9439] [RFC 9439] bw-residual See [Section 5.2 of RFC 9439] [RFC 9439] bw-available See [Section 5.3 of RFC 9439] [RFC 9439] ane-path See [Section 6.5.1 of RFC 9275] [RFC 9275] ALTO Cost Source Types Registration Procedure(s) IETF Review Reference [RFC 9439] Available Formats [IMG] CSV Identifier Intended Semantics Reference nominal Values in nominal cases ([Section 3.1 of RFC 9439]) [RFC 9439] sla Values reflecting service level agreement ([Section 3.1 of RFC 9439]) [RFC 9439] estimation Values by estimation ([Section 3.1 of RFC 9439]) [RFC 9439] ALTO Endpoint Property Types Registration Procedure(s) IETF Review Reference [RFC 7285][RFC Errata 6876] Note Identifiers prefixed with "priv:" are reserved for Private Use (see [RFC 7285, Section 10.8.2]). Available Formats [IMG] CSV Identifier Intended Semantics Reference pid See [Section 7.1.1 of RFC 7285] [RFC 7285] ALTO Address Types Registration Procedure(s) IETF Review Reference [RFC 7285] Available Formats [IMG] CSV Identifier Address Encoding Prefix Encoding Mapping to/from IPv4/v6 Reference ipv4 See [Section 10.4.3 of RFC 7285] See [Section 10.4.3 of RFC 7285] Direct mapping to IPv4 [RFC 7285] ipv6 See [Section 10.4.3 of RFC 7285] See [Section 10.4.3 of RFC 7285] Direct mapping to IPv6 [RFC 7285] ALTO Error Codes Registration Procedure(s) IETF Review Reference [RFC 7285] Available Formats [IMG] CSV Error Code Intended Usage Reference E_SYNTAX Parsing error in request (including identifiers). See [Section 8.5.2 of RFC 7285] [RFC 7285] E_MISSING_FIELD A required JSON field is missing. See [Section 8.5.2 of RFC 7285] [RFC 7285] E_INVALID_FIELD_TYPE The type of the value of a JSON field is invalid. See [Section 8.5.2 of RFC 7285] [RFC 7285] E_INVALID_FIELD_VALUE The value of a JSON field is invalid. See [Section 8.5.2 of RFC 7285] [RFC 7285] ALTO Entity Domain Types Registration Procedure(s) IETF Review Reference [RFC 9240] Available Formats [IMG] CSV Identifier Entity Identifier Encoding Hierarchy and Inheritance Media Type of Defining Resource Mapping to ALTO Address Type Reference ipv4 See [RFC 9240, Section 6.1.1] See [RFC 9240, Section 6.1.3] application/alto-networkmap+json true [RFC 9240] ipv6 See [RFC 9240, Section 6.1.2] See [RFC 9240, Section 6.1.3] application/alto-networkmap+json true [RFC 9240] pid See [RFC 9240, Section 6.2] None application/alto-networkmap+json false [RFC 9240] asn See [RFC 9241, Section 6.1.1.2] None None false [RFC 9241] countrycode See [RFC 9241, Section 6.1.2.2] None None false [RFC 9241] ane See [RFC 9275, Section 6.2.2] None application/alto-propmap+json false [RFC 9275] subdivisioncode See [RFC 9388, Section 3.1.2] None None false [RFC 9388] ALTO Entity Property Types Registration Procedure(s) IETF Review Reference [RFC 9240] Available Formats [IMG] CSV Identifier Intended Semantics Media Type of Defining Resource Reference pid See [RFC 7285, Section 7.1.1] application/alto-networkmap+json [RFC 9240] cdni-capabilities See [RFC 9241, Section 6.2] application/alto-cdni+json [RFC 9241] max-reservable-bandwidth See [RFC 9275, Section 6.4.1] application/alto-propmap+json [RFC 9275] persistent-entity-id See [RFC 9275, Section 6.4.2] application/alto-propmap+json [RFC 9275] Licensing Terms