Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About ACL TLS Created 2024-09-12 Last Updated 2026-07-13 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • ACL TLS Version Codes • ACL DTLS Version Codes • ACL (D)TLS Parameters ACL TLS Version Codes Registration Procedure(s) Expert Review Expert(s) Dan Wing, Per Andersson Reference [RFC 9761] Note When this registry is modified, the YANG module "iana-tls-profile" must be updated as defined in [RFC 9761]. Available Formats [IMG] CSV Value Label Description Reference 1 tls12 TLS Version 1.2 [RFC 5246] 2 tls13 TLS Version 1.3 [RFC 9846] ACL DTLS Version Codes Registration Procedure(s) Expert Review Expert(s) Dan Wing, Per Andersson Reference [RFC 9761] Note When this registry is modified, the YANG module "iana-tls-profile" must be updated as defined in [RFC 9761]. Available Formats [IMG] CSV Value Label Description Reference 1 dtls12 DTLS Version 1.2 [RFC 6347] 2 dtls13 DTLS Version 1.3 [RFC 9147] ACL (D)TLS Parameters Registration Procedure(s) Expert Review Expert(s) Dan Wing, Per Andersson Reference [RFC 9761] Note When this registry is modified, the YANG module "iana-tls-profile" must be updated as defined in [RFC 9761]. Available Formats [IMG] CSV Parameter Name YANG Type JSON Type Description Reference extension-type uint16 Number Extension type [RFC 9761] supported-group uint16 Number Supported group [RFC 9761] signature-algorithm uint16 Number Signature algorithm [RFC 9761] psk-key-exchange-mode uint8 Number Pre-shared key exchange mode [RFC 9761] application-protocol string String Application protocol [RFC 9761] cert-compression-algorithm uint16 Number Certificate compression algorithm [RFC 9761] cipher-algorithm uint16 Number Cipher suite [RFC 9761] tls-version enumeration String TLS version [RFC 9761] dtls-version enumeration String DTLS version [RFC 9761] Licensing Terms