Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Authentication and Authorization for Constrained Environments (ACE) Created 2021-07-27 Last Updated 2026-06-08 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • ACE Authorization Server Request Creation Hints • OAuth Error Code CBOR Mappings • OAuth Grant Type CBOR Mappings • OAuth Access Token Type CBOR Mappings • ACE Profiles • OAuth Parameters CBOR Mappings • OAuth Token Introspection Response CBOR Mappings • OSCORE Security Context Parameters • ACE Groupcomm Parameters • ACE Groupcomm Key Types • ACE Groupcomm Profiles • ACE Groupcomm Policies • Sequence Number Synchronization Methods • ACE Groupcomm Errors • ACE Groupcomm Rekeying Schemes • ACE Token Revocation List Parameters • ACE Token Revocation List Errors • Group OSCORE Roles • Group OSCORE Admin Permissions ACE Authorization Server Request Creation Hints Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action 256 to 65535 Specification Required greater than 65535 Expert Review Name CBOR Key Value Type Reference Reserved for Private Use less than -65536 [RFC 9200] AS 1 text string [RFC 9200] kid 2 byte string [RFC 9200] audience 5 text string [RFC 9200] scope 9 text or byte string [RFC 9200] cnonce 39 byte string [RFC 9200] OAuth Error Code CBOR Mappings Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 or greater Expert Review Name CBOR Value Reference Original Specification Reserved for Private Use less than -65536 [RFC 9200] invalid_request 1 [RFC 9200] [RFC 6749, Section 5.2] invalid_client 2 [RFC 9200] [RFC 6749, Section 5.2] invalid_grant 3 [RFC 9200] [RFC 6749, Section 5.2] unauthorized_client 4 [RFC 9200] [RFC 6749, Section 5.2] unsupported_grant_type 5 [RFC 9200] [RFC 6749, Section 5.2] invalid_scope 6 [RFC 9200] [RFC 6749, Section 5.2] unsupported_pop_key 7 [RFC 9200] [RFC 9200] incompatible_ace_profiles 8 [RFC 9200] [RFC 9200] OAuth Grant Type CBOR Mappings Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 or greater Expert Review Name CBOR Value Reference Original Specification Reserved for Private Use less than -65536 [RFC 9200] password 0 [RFC 9200] [RFC 6749, Section 4.3.2] authorization_code 1 [RFC 9200] [RFC 6749, Section 4.1.3] client_credentials 2 [RFC 9200] [RFC 6749, Section 4.4.2] refresh_token 3 [RFC 9200] [RFC 6749, Section 6] OAuth Access Token Type CBOR Mappings Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 or greater Expert Review Name CBOR Value Reference Original Specification Reserved for Private Use less than -65536 [RFC 9200] Bearer 1 [RFC 9200] [RFC 6749] PoP 2 [RFC 9200] [RFC 9200] ACE Profiles Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action 256 to 65535 Specification Required greater than 65535 Expert Review Name Description CBOR Value Reference Reserved for Private Use less than -65536 [RFC 9200] Profile for delegating client Authentication and Authorization for Constrained coap_dtls Environments by establishing a Datagram Transport Layer Security (DTLS) or Transport 1 [RFC 9202]; [RFC 9430] Layer Security (TLS) channel between resource-constrained nodes. coap_oscore Profile for using OSCORE to secure communication between constrained nodes using the 2 [RFC 9203] Authentication and Authorization for Constrained Environments framework. Profile for delegating Client authentication and authorization using MQTT for the Client and Broker (RS) interactions and HTTP for the AS interactions. TLS is used for mqtt_tls confidentiality and integrity protection and server authentication. Client 3 [RFC 9431] authentication can be provided either via TLS or using in-band PoP validation at the MQTT application layer. OAuth Parameters CBOR Mappings Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 or greater Expert Review Name CBOR Key Value Type Reference Original Specification Reserved for Private Use less than -65536 [RFC 9200] access_token 1 byte string [RFC 9200] [RFC 6749] expires_in 2 unsigned integer [RFC 9200] [RFC 6749] req_cnf 4 map [RFC 9201, Section 3.1] [RFC 9201] audience 5 text string [RFC 9200] [RFC 8693] cnf 8 map [RFC 9201, Section 3.2] [RFC 9201] scope 9 text or byte string [RFC 9200] [RFC 6749] client_id 24 text string [RFC 9200] [RFC 6749] client_secret 25 byte string [RFC 9200] [RFC 6749] response_type 26 text string [RFC 9200] [RFC 6749] redirect_uri 27 text string [RFC 9200] [RFC 6749] state 28 text string [RFC 9200] [RFC 6749] code 29 byte string [RFC 9200] [RFC 6749] error 30 integer [RFC 9200] [RFC 6749] error_description 31 text string [RFC 9200] [RFC 6749] error_uri 32 text string [RFC 9200] [RFC 6749] grant_type 33 unsigned integer [RFC 9200] [RFC 6749] token_type 34 integer [RFC 9200] [RFC 6749] username 35 text string [RFC 9200] [RFC 6749] password 36 text string [RFC 9200] [RFC 6749] refresh_token 37 byte string [RFC 9200] [RFC 6749] ace_profile 38 integer [RFC 9200] [RFC 9200] cnonce 39 byte string [RFC 9200] [RFC 9200] nonce1 40 bstr [RFC 9203] rs_cnf 41 map [RFC 9201, Section 3.2] [RFC 9201] nonce2 42 bstr [RFC 9203] ace_client_recipientid 43 bstr [RFC 9203] ace_server_recipientid 44 bstr [RFC 9203] sign_info 45 Null or array [RFC 9594] kdcchallenge 46 byte string [RFC 9594] ecdh_info 47 Null or array [RFC-ietf-ace-key-groupcomm-oscore-21] [RFC-ietf-ace-key-groupcomm-oscore-21] kdc_dh_creds 48 Null or array [RFC-ietf-ace-key-groupcomm-oscore-21] [RFC-ietf-ace-key-groupcomm-oscore-21] OAuth Token Introspection Response CBOR Mappings Expert(s) Göran Selander Reference [RFC 9200] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 or greater Expert Review Name CBOR Key Value Type Reference Original Specification Reserved for Private Use less than -65536 [RFC 9200] iss 1 text string [RFC 9200] [RFC 7662] sub 2 text string [RFC 9200] [RFC 7662] aud 3 text string [RFC 9200] [RFC 7662] exp 4 integer or floating-point number [RFC 9200] [RFC 7662] nbf 5 integer or floating-point number [RFC 9200] [RFC 7662] iat 6 integer or floating-point number [RFC 9200] [RFC 7662] cti 7 byte string [RFC 9200] [RFC 9200] cnf 8 map [RFC 9201, Section 4] [RFC 8705] scope 9 text or byte string [RFC 9200] [RFC 7662] active 10 True or False [RFC 9200] [RFC 7662] token 11 byte string [RFC 9200] [RFC 7662] client_id 24 text string [RFC 9200] [RFC 7662] error 30 integer [RFC 9200] [RFC 7662] error_description 31 text string [RFC 9200] [RFC 7662] error_uri 32 text string [RFC 9200] [RFC 7662] token_type_hint 33 text string [RFC 9200] [RFC 7662] token_type 34 integer [RFC 9200] [RFC 7662] username 35 text string [RFC 9200] [RFC 7662] ace_profile 38 integer [RFC 9200] [RFC 9200] cnonce 39 byte string [RFC 9200] [RFC 9200] exi 40 unsigned integer [RFC 9200] [RFC 9200] OSCORE Security Context Parameters Expert(s) Göran Selander Reference [RFC 9203] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Strings of length 1 Standards Action With Expert Review Strings of length 2 Specification Required Strings of length greater than 2 Expert Review Name CBOR Label CBOR Type Registry Description Reference Reserved for Private less than [RFC 9203] Use -65536 id 0 byte string OSCORE Input Material [RFC 9203] Identifier version 1 unsigned integer OSCORE Version [RFC 9203] ms 2 byte string OSCORE Master Secret value [RFC 9203] hkdf 3 text string / [COSE Algorithms] Values OSCORE HKDF value [RFC 9203] integer (HMAC-based) alg 4 text string / [COSE Algorithms] Values (AEAD) OSCORE AEAD Algorithm value [RFC 9203] integer salt 5 byte string an input to OSCORE Master [RFC 9203] Salt value contextId 6 byte string OSCORE ID Context value [RFC 9203] OSCORE Sender ID assigned group_SenderId 7 byte string to a member of an OSCORE [RFC-ietf-ace-key-groupcomm-oscore-21] group [COSE Header Parameters] Labels Format of authentication cred_fmt 8 integer (integer) credentials to be used in [RFC-ietf-ace-key-groupcomm-oscore-21] the OSCORE group gp_enc_alg 9 text string / [COSE Algorithms] Values OSCORE Group Encryption [RFC-ietf-ace-key-groupcomm-oscore-21] integer Algorithm Value sign_alg 10 text string / [COSE Algorithms] Values OSCORE Signature Algorithm [RFC-ietf-ace-key-groupcomm-oscore-21] integer Value [COSE Algorithms] Capabilities, OSCORE Signature Algorithm sign_params 11 array [COSE Key Types] Capabilities, Parameters [RFC-ietf-ace-key-groupcomm-oscore-21] [COSE Elliptic Curves] Values ecdh_alg 12 text string / [COSE Algorithms] Values OSCORE Pairwise Key [RFC-ietf-ace-key-groupcomm-oscore-21] integer Agreement Algorithm Value [COSE Algorithms] Capabilities, OSCORE Pairwise Key ecdh_params 13 array [COSE Key Types] Capabilities, Agreement Algorithm [RFC-ietf-ace-key-groupcomm-oscore-21] [COSE Elliptic Curves] Values Parameters ACE Groupcomm Parameters Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Strings of length 1 Standards Action With Expert Review Strings of length 2 Specification Required Strings of length greater than 2 Expert Review Name CBOR Key CBOR Type Reference Reserved for Private Use less than -65536 [RFC 9594] app_groups_diff -28 array [RFC-ietf-ace-oscore-gm-admin-17] conf_filter -27 array [RFC-ietf-ace-oscore-gm-admin-17] det_hash_alg -26 tstr or int [RFC-ietf-ace-oscore-gm-admin-17] det_req -25 True or False [RFC-ietf-ace-oscore-gm-admin-17] as_uri -19 tstr [RFC-ietf-ace-oscore-gm-admin-17] joining_uri -18 tstr [RFC-ietf-ace-oscore-gm-admin-17] app_groups -17 array [RFC-ietf-ace-oscore-gm-admin-17] gid_reuse -16 True or False [RFC-ietf-ace-oscore-gm-admin-17] max_stale_sets -15 uint [RFC-ietf-ace-oscore-gm-admin-17] group_description -14 Null or tstr [RFC-ietf-ace-oscore-gm-admin-17] group_name -13 tstr or #6.(any) [RFC-ietf-ace-oscore-gm-admin-17] active -12 True or False [RFC-ietf-ace-oscore-gm-admin-17] rt -11 tstr [RFC-ietf-ace-oscore-gm-admin-17] ecdh_params -10 Null or array [RFC-ietf-ace-oscore-gm-admin-17] ecdh_alg -9 Null or tstr or int [RFC-ietf-ace-oscore-gm-admin-17] alg -8 Null or tstr or int [RFC-ietf-ace-oscore-gm-admin-17] pairwise_mode -7 True or False [RFC-ietf-ace-oscore-gm-admin-17] sign_params -6 Null or array [RFC-ietf-ace-oscore-gm-admin-17] sign_alg -5 Null or tstr or int [RFC-ietf-ace-oscore-gm-admin-17] gp_enc_alg -4 Null or tstr or int [RFC-ietf-ace-oscore-gm-admin-17] group_mode -3 True or False [RFC-ietf-ace-oscore-gm-admin-17] cred_fmt -2 int [RFC-ietf-ace-oscore-gm-admin-17] hkdf -1 tstr or int [RFC-ietf-ace-oscore-gm-admin-17] gid 0 array [RFC 9594] gname 1 array of tstr [RFC 9594] guri 2 array of tstr [RFC 9594] scope 3 bstr [RFC 9594] get_creds 4 Null or array [RFC 9594] client_cred 5 bstr [RFC 9594] cnonce 6 bstr [RFC 9594] gkty 7 int or tstr [RFC 9594] key 8 See the [ACE Groupcomm Key Types] registry [RFC 9594] num 9 int [RFC 9594] ace_groupcomm_profile 10 int [RFC 9594] exp 11 uint [RFC 9594] exi 12 uint [RFC 9594] creds 13 array [RFC 9594] peer_roles 14 array [RFC 9594] peer_identifiers 15 array [RFC 9594] group_policies 16 map [RFC 9594] kdc_cred 17 bstr [RFC 9594] kdc_nonce 18 bstr [RFC 9594] kdc_cred_verify 19 bstr [RFC 9594] rekeying_scheme 20 int [RFC 9594] group_senderId 21 bstr [RFC-ietf-ace-key-groupcomm-oscore-21] client_cred_verify 24 bstr [RFC 9594] creds_repo 25 tstr [RFC 9594] control_uri 26 tstr [RFC 9594] mgt_key_material 27 bstr [RFC 9594] control_group_uri 28 tstr [RFC 9594] sign_info 29 Null or array [RFC 9594] kdcchallenge 30 bstr [RFC 9594] ecdh_info 31 array [RFC-ietf-ace-key-groupcomm-oscore-21] kdc_dh_creds 32 array [RFC-ietf-ace-key-groupcomm-oscore-21] sign_enc_key 33 bstr [RFC-ietf-ace-key-groupcomm-oscore-21] stale_node_ids 34 array [RFC-ietf-ace-key-groupcomm-oscore-21] ACE Groupcomm Key Types Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Strings of length 1 Standards Action With Expert Review Strings of length 2 Specification Required Strings of length greater than 2 Expert Review Key Name Type Profile Description Reference Value less Reserved for Private Use than [RFC 9594] -65536 Reserved 0 This value is reserved [RFC 9594] "coap_group_oscore_app", registered in A Group_OSCORE_Input_Material object Group_OSCORE_Input_Material 1 [RFC-ietf-ace-key-groupcomm-oscore-21, encoded as described in [RFC-ietf-ace-key-groupcomm-oscore-21] object Section 17.5] [RFC-ietf-ace-key-groupcomm-oscore-21, Section 6.3] ACE Groupcomm Profiles Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Name Description CBOR Value Reference Reserved for Private Use less than -65536 [RFC 9594] Reserved This value is reserved 0 [RFC 9594] Application profile to provision keying material for participating in coap_group_oscore_app group communication protected with Group OSCORE as per 1 [RFC-ietf-ace-key-groupcomm-oscore-21] [draft-ietf-core-oscore-groupcomm] ACE Groupcomm Policies Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Strings of length 1 Standards Action With Expert Review Strings of length 2 Specification Required Strings of length greater than 2 Expert Review Name CBOR Label CBOR Type Description Reference Reserved for Private Use less than -65536 [RFC 9594] Method for recipient group members to synchronize with sequence numbers Sequence Number Synchronization Method 0 int or tstr of sender group members. Its value is taken from the "Value" column of [RFC 9594] the "Sequence Number Synchronization Method" registry Key Update Check Interval 1 int Polling interval in seconds, for group members to check at the KDC if [RFC 9594] the latest group keying material is the one that they store Number of seconds from 'exp' until a UTC date/time, after which group Expiration Delta 2 uint members MUST stop using the group keying material that they store to [RFC 9594] decrypt incoming messages Sequence Number Synchronization Methods Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Strings of length 1 Standards Action With Expert Review Strings of length 2 Specification Required Strings of length greater than 2 Expert Review Name Value Description Reference Reserved for Private Use less than -65536 [RFC 9594] ACE Groupcomm Errors Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Value Description Reference less than -65536 Reserved for Private Use [RFC 9594] 0 Operation permitted only to group members [RFC 9594] 1 Request inconsistent with the current roles [RFC 9594] 2 Authentication credential incompatible with the group configuration [RFC 9594] 3 Invalid proof-of-possession evidence [RFC 9594] 4 No available individual keying material [RFC 9594] 5 Group membership terminated [RFC 9594] 6 Group deleted [RFC 9594] 7 Signatures not used in the group [RFC-ietf-ace-key-groupcomm-oscore-21] 8 Operation permitted only to signature verifiers [RFC-ietf-ace-key-groupcomm-oscore-21] 9 Group currently not active [RFC-ietf-ace-key-groupcomm-oscore-21] 10 Group currently active [RFC-ietf-ace-oscore-gm-admin-17] 11 Unable to determine a group name [RFC-ietf-ace-oscore-gm-admin-17] 12 Unsupported group configuration [RFC-ietf-ace-oscore-gm-admin-17] ACE Groupcomm Rekeying Schemes Expert(s) Francesca Palombini, Marco Tiloca, Rikard Höglund Reference [RFC 9594] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Value Name Description Reference Reserved for Private Use less than -65536 [RFC 9594] 0 Point-to-Point The KDC individually targets each node to rekey, using the pairwise secure communication [RFC 9594] association with that node ACE Token Revocation List Parameters Expert(s) Marco Tiloca, Marco Rasori Reference [RFC 9770] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Name CBOR Key CBOR Type Reference Reserved for Private Use less than -65536 [RFC 9770] Unassigned -65536..-1 full_set 0 array [RFC 9770] diff_set 1 array [RFC 9770] cursor 2 Null or unsigned integer [RFC 9770] more 3 True or False [RFC 9770] ACE Token Revocation List Errors Expert(s) Marco Tiloca, Marco Rasori Reference [RFC 9770] Available Formats [IMG] CSV Range Registration Procedures less than -65536 Private Use -65536 to -257 Specification Required -256 to 255 Standards Action With Expert Review 256 to 65535 Specification Required greater than 65535 Expert Review Value Description Reference less than -65536 Reserved for Private Use [RFC 9770] -65536..-1 Unassigned 0 Invalid parameter value [RFC 9770] 1 Invalid set of parameters [RFC 9770] 2 Out of bound cursor value [RFC 9770] Group OSCORE Roles Expert(s) Unassigned Reference [RFC-ietf-ace-key-groupcomm-oscore-21] Available Formats [IMG] CSV Range Registration Procedures 0-65535 Expert Review greater than 65535 Private Use Value Name Description Reference 0 Reserved This value is reserved [RFC-ietf-ace-key-groupcomm-oscore-21] 1 Requester Send protected requests; receive protected responses [RFC-ietf-ace-key-groupcomm-oscore-21] 2 Responder Send protected responses; receive protected requests [RFC-ietf-ace-key-groupcomm-oscore-21] 3 Monitor Receive protected requests; never send protected messages [RFC-ietf-ace-key-groupcomm-oscore-21] 4 Verifier Verify signature of intercepted messages protected with the group [RFC-ietf-ace-key-groupcomm-oscore-21] mode 5-65535 Unassigned Unassigned greater than 65535 Reserved for Private Use Reserved for Private Use [RFC-ietf-ace-key-groupcomm-oscore-21] Group OSCORE Admin Permissions Expert(s) Unassigned Reference [RFC-ietf-ace-oscore-gm-admin-17] Available Formats [IMG] CSV Range Registration Procedures 0-65535 Expert Review greater than 65535 Private Use Name Value Description Reference List 0 Retrieve list of group configurations [RFC-ietf-ace-oscore-gm-admin-17] Create 1 Create new group configurations [RFC-ietf-ace-oscore-gm-admin-17] Read 2 Retrieve group configurations [RFC-ietf-ace-oscore-gm-admin-17] Write 3 Change group configurations [RFC-ietf-ace-oscore-gm-admin-17] Delete 4 Delete group configurations [RFC-ietf-ace-oscore-gm-admin-17] Unassigned 5-65535 Reserved for Private Use greater than 65535 [RFC-ietf-ace-oscore-gm-admin-17] Licensing Terms