Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IPv6 Over the TSCH Mode of IEEE 802.15.4 (6TiSCH) Created 2018-08-20 Last Updated 2021-06-21 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • 6P Version Numbers • 6P Message Types • 6P Command Identifiers • 6P Return Codes • 6P Scheduling Function Identifiers • 6P CellOptions Bitmap • Constrained Join Protocol (CoJP) Parameters • Constrained Join Protocol (CoJP) Key Usage • Constrained Join Protocol (CoJP) Unsupported Configuration Codes 6P Version Numbers Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8480] Note In the 6top Protocol (6P) [RFC 8480], there is a field to identify the version of the protocol. This field is 4 bits in size. Available Formats [IMG] CSV Version Reference 0 [RFC 8480] 6P Message Types Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8480] Note In the 6top Protocol (6P) version 0 [RFC 8480], there is a field to identify the type of message. This field is 2 bits in size. Available Formats [IMG] CSV Type Name Reference b00 REQUEST [RFC 8480] b01 RESPONSE [RFC 8480] b10 CONFIRMATION [RFC 8480] b11 Unassigned 6P Command Identifiers Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8480] Note In the 6top Protocol (6P) version 0 [RFC 8480], there is a Code field which is 8 bits in size. In a 6P Request, the value of this Code field is used to identify the command. Available Formats [IMG] CSV Identifier Name Reference 0 Reserved [RFC 8480] 1 ADD [RFC 8480] 2 DELETE [RFC 8480] 3 RELOCATE [RFC 8480] 4 COUNT [RFC 8480] 5 LIST [RFC 8480] 6 SIGNAL [RFC 8480] 7 CLEAR [RFC 8480] 8-254 Unassigned 255 Reserved [RFC 8480] 6P Return Codes Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8480] Note In the 6top Protocol (6P) version 0 [RFC 8480], there is a Code field which is 8 bits in size. In a 6P Response or 6P Confirmation, the value of this Code field is used to identify the return code. Available Formats [IMG] CSV Code Name Description Is Error? Reference 0 RC_SUCCESS operation succeeded No [RFC 8480] 1 RC_EOL end of list No [RFC 8480] 2 RC_ERR generic error Yes [RFC 8480] 3 RC_RESET critical error, reset Yes [RFC 8480] 4 RC_ERR_VERSION unsupported 6P version Yes [RFC 8480] 5 RC_ERR_SFID unsupported SFID Yes [RFC 8480] 6 RC_ERR_SEQNUM schedule inconsistency Yes [RFC 8480] 7 RC_ERR_CELLLIST cellList error Yes [RFC 8480] 8 RC_ERR_BUSY busy Yes [RFC 8480] 9 RC_ERR_LOCKED cells are locked Yes [RFC 8480] 10-255 Unassigned 6P Scheduling Function Identifiers Expert(s) Xavi Vilajosana Guillen, Thomas Watteyne Reference [RFC 8480] Note In the 6top Protocol (6P) version 0 [RFC 8480], there is a field to identify the scheduling function to handle the message. This field is 8 bits in size. Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review or IESG Approval 128-255 Expert Review SFID Name Reference 0 Minimal Scheduling Function (MSF) [RFC 9033] 1-255 Unassigned 6P CellOptions Bitmap Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8480] Note In the 6top Protocol (6P) version 0 [RFC 8480], there is an optional CellOptions field which is 8 bits in size. Available Formats [IMG] CSV Bit Name Reference 0 TX (Transmit) [RFC 8480] 1 RX (Receive) [RFC 8480] 2 SHARED [RFC 8480] 3-7 Unassigned Constrained Join Protocol (CoJP) Parameters Expert(s) Mališa Vučinić, Michael Richardson Reference [RFC 9031] Available Formats [IMG] CSV Range Registration Procedures Integer values less than -65536 Private Use Integer values from -65536 to -257 Specification Required Integer values from -256 to 255 Standards Action Integer values from 256 to 65535 Specification Required Integer values greater than 65535 Expert Review Name Label CBOR Type Description Reference Reserved for Private Use less than -65536 [RFC 9031] Unassigned -65536 to 0 [RFC 9031] role 1 unsigned integer Identifies the role parameter [RFC 9031] link-layer key set 2 array Identifies the array carrying one or more link-level cryptographic keys [RFC 9031] short identifier 3 array Identifies the assigned short identifier [RFC 9031] JRC address 4 byte string Identifies the IPv6 address of of the JRC [RFC 9031] network identifier 5 byte string Identifies the network identifier parameter [RFC 9031] blacklist 6 array Identifies the blacklist parameter [RFC 9031] join rate 7 unsigned integer Identifies the join rate parameter [RFC 9031] unsupported configuration 8 array Identifies the unsupported configuration parameter [RFC 9031] Constrained Join Protocol (CoJP) Key Usage Expert(s) Mališa Vučinić, Michael Richardson Reference [RFC 9031] Available Formats [IMG] CSV Range Registration Procedures Integer values less than -65536 Private Use Integer values from -65536 to -257 Specification Required Integer values from -256 to 255 Standards Action Integer values from 256 to 65535 Specification Required Integer values greater than 65535 Expert Review Name Value Algorithm Description Reference Reserved for Private Use less than -65536 [RFC 9031] Unassigned -65536 to -1 [RFC 9031] 6TiSCH-K1K2-ENC-MIC32 0 IEEE802154-AES-CCM-128 Use MIC-32 for EBs, ENC-MIC-32 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K1K2-ENC-MIC64 1 IEEE802154-AES-CCM-128 Use MIC-64 for EBs, ENC-MIC-64 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K1K2-ENC-MIC128 2 IEEE802154-AES-CCM-128 Use MIC-128 for EBs, ENC-MIC-128 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K1K2-MIC32 3 IEEE802154-AES-CCM-128 Use MIC-32 for EBs, DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K1K2-MIC64 4 IEEE802154-AES-CCM-128 Use MIC-64 for EBs, DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K1K2-MIC128 5 IEEE802154-AES-CCM-128 Use MIC-128 for EBs, DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K1-MIC32 6 IEEE802154-AES-CCM-128 Use MIC-32 for EBs. [RFC 9031] 6TiSCH-K1-MIC64 7 IEEE802154-AES-CCM-128 Use MIC-64 for EBs. [RFC 9031] 6TiSCH-K1-MIC128 8 IEEE802154-AES-CCM-128 Use MIC-128 for EBs. [RFC 9031] 6TiSCH-K2-MIC32 9 IEEE802154-AES-CCM-128 Use MIC-32 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K2-MIC64 10 IEEE802154-AES-CCM-128 Use MIC-64 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K2-MIC128 11 IEEE802154-AES-CCM-128 Use MIC-128 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K2-ENC-MIC32 12 IEEE802154-AES-CCM-128 Use ENC-MIC-32 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K2-ENC-MIC64 13 IEEE802154-AES-CCM-128 Use ENC-MIC-64 for DATA and ACKNOWLEDGMENT. [RFC 9031] 6TiSCH-K2-ENC-MIC128 14 IEEE802154-AES-CCM-128 Use ENC-MIC-128 for DATA and ACKNOWLEDGMENT. [RFC 9031] Constrained Join Protocol (CoJP) Unsupported Configuration Codes Expert(s) Mališa Vučinić, Michael Richardson Reference [RFC 9031] Available Formats [IMG] CSV Range Registration Procedures Integer values less than -65536 Private Use Integer values from -65536 to -257 Specification Required Integer values from -256 to 255 Standards Action Integer values from 256 to 65535 Specification Required Integer values greater than 65535 Expert Review Name Value Description Reference Reserved for Private Use less than -65536 [RFC 9031] Unassigned -65536 to -1 [RFC 9031] Unsupported 0 The indicated setting is not supported by the networking stack implementation. [RFC 9031] Malformed 1 The indicated parameter value is malformed. [RFC 9031] Licensing Terms